joomla_antivirus_logo

Autor Tema: Kako prijeći na Joomlu 3 s Joomle 2.5?  (Posjeta: 14708 )

0 Članova i 1 Gost pregledava ovu temu.

Nathan_01

  • Novi forumaš
  • *
  • Postova: 39
  • Karma: 1
    • Profil
Kako prijeći na Joomlu 3 s Joomle 2.5?
« : 08. Svibanj 2013, 19:33 »
Pokušao sam ovako:

Go to the Joomla! Update component. Click on options and change the setting to Short Term Support. Save. You should be notified of the availability of Joomla 3.x. Click the button to install

No ne ponudi mi nikakav upgrade moje Joomle. Piše mi samo da imam zadnju verziju:

You already have the latest Joomla! version, 2.5.11.

Isto tako u Softaculusu nema ništa za upgrade.

Prešao bi ja Joomlu 3 zbog tagove, jer je to novost koja mi je oduvijek bila potrebna da ne moram koristit dodatke za članke koji se nalaze u više kategorija.

Molim pomoć.

Nathan_01

  • Novi forumaš
  • *
  • Postova: 39
  • Karma: 1
    • Profil
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #1 : 08. Svibanj 2013, 22:14 »
Moram napisati da je podrška na ovom forumu jako slaba, tj. nikakva.
Valjda najslabija. Na postove odgovarate u razmaku od par dana što je neprihvatljivo za jedan Forum Help za ovu skriptu.
Ne znam jel ovo privatan forum ili baš forum Joomla zajednice u RH, no jako slabo.

Lijep pozdrav

triolatice

  • Forumaš
  • ***
  • Postova: 119
  • Karma: 0
    • Profil
    • Joomla developing
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #2 : 08. Svibanj 2013, 22:47 »
Poštovani,
prije svega članovi ovoga foruma ne predstavljaju support ni za Joomla CMS, niti za dodatke koje koristi Joomla, pa prema tome iluzorno je očekivati da  je netko dužan promtno reagirati na tvoje upite. Sve je stvar dobre volje članova ovoga foruma, dali će ti netko uopće odgovoriti i kada će ti odgovoriti. Kada ćeš trebati promtnu i profesionalnu pomoć od osoba koje dobro poznaju Joomla CMS onda im ponudi i odgovarajuću nadoknadu za rješavanje tvojih osobnih problema . Iz tvoga pitanja nameće mi se se pomisao da se nisi nimalo potrudio da se informiraš o Joomla HR zajednici koja godinama nesebično pomaže mnogobrojnim korisnicima Joomle koji se po prvi puta sa njom susreću.
Također nisam uvjerem da razuješ što je uopće Joomla , jer je vjerojano nebi nazivao "skriptom".
Vjerojatno ti nebi nedostajalo i malo pristojnosti u svojim pitanjima, jer ja se osobno osječam uvrijeđenim tvojim nastupom.


Onebeat

  • Global Moderator
  • *****
  • Postova: 728
  • Karma: 10
  • Ajmo sada za ozbiljno....
    • Profil
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #3 : 09. Svibanj 2013, 07:13 »
Moram napisati da je podrška na ovom forumu jako slaba, tj. nikakva.
Valjda najslabija. Na postove odgovarate u razmaku od par dana što je neprihvatljivo za jedan Forum Help za ovu skriptu.
Ne znam jel ovo privatan forum ili baš forum Joomla zajednice u RH, no jako slabo.

Lijep pozdrav

Pozdrav,

pročitao sam tekst čim je postan i nisam odgovorio jer

1. nisam uopće shvatio pitanje na prvo čitanje koje se nalazi u naslovu teksta
2. jesi uopće pitao google, pa bi nasao npr ovo ili ovo ili ovo
3. ova zajednica je skupina ljudi koji vole joomlu i svu njezinu djecu (komponenete,module,pluginove i template) a nije nipošto organizacija koja stoji iza joomle - za konkretan službeni forum na hrvatskom jeziku pogledaj ovdje
4. moram se složit sa kolegom @triolaticom jer mi uopće ne sviđa kada pročitam tvoj tekst u više navrata kako mi to zvuči
5. na ovom forumu sam u ovom ili onom obliku od 2005 godine i nesjećam se da je netko tako došao i na prvu odmah "oprao" ekipu koja uza sve svoje obveze pomaže ljudima kada STIGNE i MOŽE pa makar to bilo u razmaku od par sati
6. neznam što bi više napisao
Truth will set you free

ikiK

  • Global Moderator
  • *****
  • Postova: 877
  • Karma: 7
    • Profil
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #4 : 09. Svibanj 2013, 10:32 »
Škandalozno :)
...

Dario

  • Global Moderator
  • *****
  • Postova: 1.022
  • Karma: 26
  • Web/Joomla Developer
    • Profil
    • dBlaze
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #5 : 09. Svibanj 2013, 11:03 »
Moram napisati da je podrška na ovom forumu jako slaba, tj. nikakva.
Valjda najslabija. Na postove odgovarate u razmaku od par dana što je neprihvatljivo za jedan Forum Help za ovu skriptu.
Ne znam jel ovo privatan forum ili baš forum Joomla zajednice u RH, no jako slabo.

Lijep pozdrav

Pa lijep pozdrav i tebi. Ja ću se samo nadovezati na ono što ti je ekipa već napisala i reći da si stvarno svašta dopuštaš... Prije nego što slijedeći puta tresneš ovakvu glupost, možeš i razmisliti koji je razlog što ti mi, nazovimo to iskusniji, s višegodišnjim iskustvom uopće želimo pomoći s obzirom da nam je nekim to posao i kruh pa teoretski sami sebi skačemo u želudac.

Ako želiš da se nešto odradi za tebe ili mora biti gotovo "jučer" - imaš sekciju foruma s komercijalnim uslugama pa probaj tamo, a za sve ostalo se malo spusti na zemlji. Ne znam koliko je teško shvati da uz posao i privatan život baš ne možemo visjeti cijele dane na forumu i čekati da jedan Nathan ovori, a mi svi odma hop.... Budi realan malo i strpljiv.

Ja sam na forumu 1-2 puta dnevno, pregledam sve teme "od moje zadnje posjete" i odgovorim ako je pitanje na mjestu ili imam nešto za dodati na već odgovoreno, pa ti sebe sad probaj naći u ovoj rečenici.

Pa sad evo odgovora na tvoja pitanja - koliko je god to moguće....

Go to the Joomla! Update component. Click on options and change the setting to Short Term Support. Save. You should be notified of the availability of Joomla 3.x. Click the button to install
No ne ponudi mi nikakav upgrade moje Joomle. Piše mi samo da imam zadnju verziju:
You already have the latest Joomla! version, 2.5.11.
Ako je to tako kako si napisao (osobno nisam još upgrade s 2.5 na 3.x), jedino mi pada na pamet da odeš za početak u provjeru dostupnosti ažuriranja (početni backend screen - zadnja ikona u QuickIcons tab-u) pa tamo probaš očistiti cache, ponovno "provjeriti ažuriranja" i potom se vratiti na početni screen i vidjeti da li se što promjenilo. Kažem, nisam radi još to - ali vrijedi pokušati...

Isto tako u Softaculusu nema ništa za upgrade.
Normalno da nema je jer je Softaculusu aplikacija/skripta/komponenta cPanela koja ti samo omogućuje one-click install predefiniranih aplikacija - i ništa drugo... .To što ti želiš upgrade nečega je već malo složeniji proces.
---
Molim da mi ne šaljete privatne poruke sa zahtjevima za pomoć, takve poruke ignoriram - zato služi forum :)
2b || !2b; this.question();
http://www.dblaze.eu

Nathan_01

  • Novi forumaš
  • *
  • Postova: 39
  • Karma: 1
    • Profil
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #6 : 10. Svibanj 2013, 00:10 »
Stvarno sam si dopustio previše i ispričavam se svima na jučerašnjem postu i iskreno mi je što sam vas maltene 'napao'.
Naime, cijeli dan mi je bio užasan i onda sam još zabrljao cijelu stranicu i na kraju izgubio živce, to nije opravdanje, već samo razlog.
Naravno da ne očekujem da itko visi po forumu iskače na upite, ne radim to ni ja.

No zbilja šteta da ovaj forum nije aktivniji. Ne zbog upita, već što vjerujem da ima puno ljudi koji koriste Joomlu kao CMS i ovakav jedan forum je zbilja koristan i potreban.
Možda je to moj krivi dojam neaktivnosti, u svakom slučaju, zbilja mi je žao zbog jučerašnjeg nastupa.

Što se tiče same teme, prešao sam na Joomlu 3, no nikako mi nije htio proraditi template, ustvari nije htio uopće otvoriti stranicu već je stalno otvarao error:

Warning: require_once(/home/postovic/public_html/hororvizija.net/templates/jsn_epic_freeDSincludesDSlibDSjsn_utils.php) [function.require-once]: failed to open stream: No such file or directory in /home/postovic/public_html/hororvizija.net/templates/jsn_epic_free/index.php on line 15

Fatal error: require_once() [function.require]: Failed opening required '/home/postovic/public_html/hororvizija.net/templates/jsn_epic_freeDSincludesDSlibDSjsn_utils.php' (include_path='.:/usr/lib/php') in /home/postovic/public_html/hororvizija.net/templates/jsn_epic_free/index.php on line 15.

Još jednom, sorry.

Dario

  • Global Moderator
  • *****
  • Postova: 1.022
  • Karma: 26
  • Web/Joomla Developer
    • Profil
    • dBlaze
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #7 : 10. Svibanj 2013, 08:25 »
Stvarno sam si dopustio previše i ispričavam se svima na jučerašnjem postu i iskreno mi je što sam vas maltene 'napao'.
Naime, cijeli dan mi je bio užasan i onda sam još zabrljao cijelu stranicu i na kraju izgubio živce, to nije opravdanje, već samo razlog.
Naravno da ne očekujem da itko visi po forumu iskače na upite, ne radim to ni ja.
Apology excepted, svi imamo žute minute - nije to ništ novo :)

Što se tiče same teme, prešao sam na Joomlu 3, no nikako mi nije htio proraditi template, ustvari nije htio uopće otvoriti stranicu već je stalno otvarao error:

Warning: require_once(/home/postovic/public_html/hororvizija.net/templates/jsn_epic_freeDSincludesDSlibDSjsn_utils.php) [function.require-once]: failed to open stream: No such file or directory in /home/postovic/public_html/hororvizija.net/templates/jsn_epic_free/index.php on line 15

Fatal error: require_once() [function.require]: Failed opening required '/home/postovic/public_html/hororvizija.net/templates/jsn_epic_freeDSincludesDSlibDSjsn_utils.php' (include_path='.:/usr/lib/php') in /home/postovic/public_html/hororvizija.net/templates/jsn_epic_free/index.php on line 15.

E vidi sad.... neznam jel su kompatibilni template-ovi 2.5 i 3.0 ali ovdje kod tebe koliko vidim se događa da ti se putanja ne isparsa dobro, točnije, koliko vidim iz ovog koda - izgleda da su u J3.x izbacili DS (directory separator) konstantu, što mi je malo čudno... Evo jedno rješenje koje mislim da bi trebalo raditi...

1. otvori datoteku templates/jsn_epic_free/index.php
bilo što da se nalazi u prvom redu, pomakni jedan redak dolje, a u prvi red stavi ovo
<?php if(!defined('DS')) define('DS'DIRECTORY_SEPARATOR); ?>

Ovim ćeš se riješiti dotični problem, odnosno ne bi zbog ove "greške" trebao više pucati PHP, jer kod require_once koja se koristi kod tebe (za razliku od include)funkcije ako se datoteka ne učita - tu je priči kraj, puca PHP i dobiješ ove errore... Prvo svakako napravi ovo gore napisano pa nam javi kakvi su rezultati :)
---
Molim da mi ne šaljete privatne poruke sa zahtjevima za pomoć, takve poruke ignoriram - zato služi forum :)
2b || !2b; this.question();
http://www.dblaze.eu

Nathan_01

  • Novi forumaš
  • *
  • Postova: 39
  • Karma: 1
    • Profil
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #8 : 10. Svibanj 2013, 12:15 »
Pozdrav i hvala na prihvaćanju isprike.

Probao sam ovo što si stavio, no i dalje prijavljuje istu grešku, evo ti početak tog index.phpa:

<?php
/**
* @author    JoomlaShine.com http://www.joomlashine.com
* @copyright Copyright (C) 2008 - 2011 JoomlaShine.com. All rights reserved.
* @license   GNU/GPL v2 http://www.gnu.org/licenses/gpl-2.0.html
 */

   // No direct access
 
defined('_JEXEC') or die('Restricted index access');
define('YOURBASEPATH'dirname(__FILE__));

   
JHTML::_('behavior.framework'false);

// Template setup
  
require_once(YOURBASEPATH.DS.'includes'.DS.'lib'.DS.'jsn_utils.php');
  require_once(
YOURBASEPATH.DS.'includes'.DS.'jsn_config.php');
  require_once(
YOURBASEPATH.DS.'includes'.DS.'jsn_setup.php');

?>

ikiK

  • Global Moderator
  • *****
  • Postova: 877
  • Karma: 7
    • Profil
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #9 : 10. Svibanj 2013, 12:35 »
Čisto sumnjam da će template proradit na 3.0 ovim jednostavim fixom ako već nije optimiziran i namjenjen za 3.0 od strane dizajnera (a ovo pitanje još visi u zraku).
Postoji velika mogućnost drugih problema ako se i otkloni dotična greška.
No nisam previše istraživao pa me ispravite ako griješim.

Edit; malo sam prelistao dotičnu JoomlaShine.com stranicu i večina ima support za 3.0, imaš li zadnju verziju template?
« Zadnja izmjena: 10. Svibanj 2013, 12:50 ikiK »
...

Nathan_01

  • Novi forumaš
  • *
  • Postova: 39
  • Karma: 1
    • Profil
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #10 : 10. Svibanj 2013, 12:42 »
Evo ovdje je uzet template, za koji tvrde da radi i ja Joomli 3
http://www.joomlashine.com/joomla-templates/jsn-epic-download.html

Možda se varam, ne znam.

ikiK

  • Global Moderator
  • *****
  • Postova: 877
  • Karma: 7
    • Profil
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #11 : 10. Svibanj 2013, 12:49 »
Da primjetio sam i editirao sam gore post.
Dok čekaš da ti se kolega javi u vezi ovog, jesi li probao jednostavno re-install napravit preko administracije, možda zvući trivijalno ali ja volim počet od takvih stvari?
Samo pazi da beckupiraš fajlove predloška na kojima si eventualno radio preinake.
« Zadnja izmjena: 10. Svibanj 2013, 15:08 ikiK »
...

Nathan_01

  • Novi forumaš
  • *
  • Postova: 39
  • Karma: 1
    • Profil
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #12 : 10. Svibanj 2013, 17:41 »
Jesam, probao sam, no opet ništa, ustvari ni ne da mi ponovo instal template.
A vratit ću na Joomlu 2.5 pa neka ostane, ne mogu više gubiti živce :D

Dario

  • Global Moderator
  • *****
  • Postova: 1.022
  • Karma: 26
  • Web/Joomla Developer
    • Profil
    • dBlaze
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #13 : 13. Svibanj 2013, 08:19 »
Ovako bi trebalo izgledat inače i onda se nebi smio više pojavljivat ovaj error sa DS konstantom.... probaj ovako, isprazni error log pa vidi onda što se događa....

<?php
/**
* @author    JoomlaShine.com http://www.joomlashine.com
* @copyright Copyright (C) 2008 - 2011 JoomlaShine.com. All rights reserved.
* @license   GNU/GPL v2 http://www.gnu.org/licenses/gpl-2.0.html
 */

   // No direct access
defined('_JEXEC') or die('Restricted index access');
define('YOURBASEPATH'dirname(__FILE__));
if(!
defined('DS')) define('DS'DIRECTORY_SEPARATOR);

   
JHTML::_('behavior.framework'false);

// Template setup
  
require_once(YOURBASEPATH.DS.'includes'.DS.'lib'.DS.'jsn_utils.php');
  require_once(
YOURBASEPATH.DS.'includes'.DS.'jsn_config.php');
  require_once(
YOURBASEPATH.DS.'includes'.DS.'jsn_setup.php');
?>

« Zadnja izmjena: 05. Rujan 2014, 11:21 Dario [ORION] »
---
Molim da mi ne šaljete privatne poruke sa zahtjevima za pomoć, takve poruke ignoriram - zato služi forum :)
2b || !2b; this.question();
http://www.dblaze.eu

triolatice

  • Forumaš
  • ***
  • Postova: 119
  • Karma: 0
    • Profil
    • Joomla developing
Odg: Kako prijeći na Joomlu 3 s Joomle 2.5?
« Odgovori #14 : 13. Svibanj 2013, 20:17 »
Ja sam napravio prelaz iz Joomle 2.5 na 3.0 . Rezultat , ne prikazuje se sadržaj. Odustao. Sreča da sam prije toga napravio backup. Prelazak , ne hvala za sada.


Gledao sam malo taj predložak i nije mi ništa jasno. Source kod koji si nam prikazao ja ne vidim nigdje (gledam u index.php samoga predloška ) . Grešku koja se tebi prikazuje odnosi se na datoteku u folderu  "/includes/lib/" unutar samoga predloška. Međutim toga foldera nigdje nema , nema ga na verziji 2.5 ni 3.0. također nema ga ni u verzijama za quickstart.


Nisam siguran ima li to veze sa pluginom koji se instalira online. Provjeri dali imaš folder "plugins/system/jsnframework/" .


Meni predložak radi i na 2.5.11  i na 3.1

 

joomla_antivirus_logo